Issue with Help Chat / Emails
Incident Report for Big Team Challenge
Resolved
Our help chat functionality has been restored to normal and we are marking this incident as resolved.

Please continue to reach out via the help chat or via email if you have any questions or issues.
Posted Feb 22, 2024 - 12:08 GMT
Monitoring
Our help chat provider has implemented a mitigation which restores most of the chat functionality. We will monitor for any further updates.

As well as via email, Big Team Challenge will now reply to any messages received through our help chat.
Posted Feb 22, 2024 - 11:02 GMT
Update
Our help chat provider is working on fixing their incident but have not shared an ETA for restoration of all functionality.

Since Big Team Challenge technical support are currently unable to reply via the chat, we recommend emailing contact@bigteamchallenge.com if you have an urgent issue.
Posted Feb 22, 2024 - 10:38 GMT
Investigating
Our help chat / email provider is experiencing an incident that is affecting Big Team Challenge technical support - https://www.intercomstatus.com/incidents/15h532sk1ytv.

We will get back to any messages received as soon as the incident is resolved. If you need help please visit https://help.bigteamchallenge.com or email us on contact@bigteamchallenge.com.

We apologise for the inconvenience caused by this unforeseen incident outside of our control.
Posted Feb 22, 2024 - 09:39 GMT
This incident affected: Help and Support.